summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorBenjamin <benjamin@uvy.fr>2023-11-18 19:17:30 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-08 21:46:22 +0000
commit98f8a2a34e36b806d85129207243d4c939081ef5 (patch)
tree0ce2b7565e88f16c2ac742d872b6e8c17259a23d /gnu/packages/golang-xyz.scm
parentd6866b6cbee4920439be86916dab3c830746f5ea (diff)
gnu: Add go-go-uber-org-automaxprocs.
* gnu/packages/golang-xyz.scm (go-go-uber-org-automaxprocs): New variable. Change-Id: I06abcaf3f3b74e23e5808d4ff37a93a0dc45b137 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 48f56c4244..b7c6cec1c2 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
@@ -143,6 +144,31 @@ Differentiation between text and binary files}.
(description "This package provides an idiomatic Go retry module.")
(license license:expat)))
+(define-public go-go-uber-org-automaxprocs
+ (package
+ (name "go-go-uber-org-automaxprocs")
+ (version "1.5.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uber-go/automaxprocs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03arxcfaj7k6iwfdk0liaynxf9rjfj9m5glsjp7ws01xjkgrdpbc"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "go.uber.org/automaxprocs"))
+ (native-inputs (list go-github-com-stretchr-testify
+ go-github-com-prashantv-gostub))
+ (home-page "https://github.com/uber-go/automaxprocs")
+ (synopsis "CPU-count detection library for Go")
+ (description
+ "This package automatically set GOMAXPROCS to match Linux container
+CPU quota.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar