summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-01-17 22:38:38 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 22:59:13 +0000
commitba17880abd18b59eaf41e04893ce019cb1724814 (patch)
tree3e57213cee7946aadc25e073181eb7b8dc61b91d /gnu/packages/golang-xyz.scm
parentcfeec48158d2a52ce4fc9d560075ffba1f3b6822 (diff)
gnu: Add go-github-com-coreos-go-systemd-journal.
* gnu/packages/golang.scm (go-github-com-coreos-go-systemd-journal): New variable. Change-Id: I6a8ae9d416ce7c4236ce0d8a8388da130964144c Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c968b0018b..2bb68ecb86 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -257,6 +257,19 @@ status changes")))
(description "Go bindings to systemd for starting/stopping/inspecting
running services and units.")))
+(define-public go-github-com-coreos-go-systemd-journal
+ (package
+ (inherit go-github-com-coreos-go-systemd-activation)
+ (name "go-github-com-coreos-go-systemd-journal")
+ (arguments
+ '(#:tests? #f ;Tests require access to journald socket.
+ #:import-path "github.com/coreos/go-systemd/journal"
+ #:unpack-path "github.com/coreos/go-systemd"))
+ (home-page "https://github.com/coreos/go-systemd")
+ (synopsis "Go bindings to systemd for writing journald")
+ (description "Go bindings to systemd for writing to systemd's logging
+service, journald.")))
+
(define-public go-github-com-cyberdelia-go-metrics-graphite
(package
(name "go-github-com-cyberdelia-go-metrics-graphite")