summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorDominic Martinez <dom@dominicm.dev>2024-02-11 19:28:19 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:22 +0000
commiteeda1c1cbc478d89c47aed941282394f5ef5192e (patch)
tree80469f2d532676f3b18faf689af8d60134c72b9c /gnu/packages/golang-xyz.scm
parenta90bc5030d948343f0e4791057f568ce8f2d1dfc (diff)
gnu: Add go-github-com-miekg-dns.
* gnu/packages/golang-xyz.scm (go-github-com-miekg-dns): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I095c6a7a709614d2cbd1feb9488dfee47a35da57
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index dafbbfea30..7964b0b5e2 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -215,6 +215,36 @@ Differentiation between text and binary files}.
(description "This package provides an idiomatic Go retry module.")
(license license:expat)))
+(define-public go-github-com-miekg-dns
+ (package
+ (name "go-github-com-miekg-dns")
+ (version "1.1.48")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/miekg/dns")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14m4wnbgmc1prj4ds1fsz1nwb1awaq365lhbp8clzsidxmhjf3hl"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/miekg/dns"))
+ (propagated-inputs
+ (list go-golang-org-x-tools
+ go-golang-org-x-sys
+ go-golang-org-x-sync
+ go-golang-org-x-net))
+ (home-page "https://github.com/miekg/dns")
+ (synopsis "Domain Name Service library in Go")
+ (description
+ "This package provides a fully featured interface to the @acronym{DNS,
+Domain Name System}. Both server and client side programming is supported.
+The package allows complete control over what is sent out to the @acronym{DNS,
+Domain Name Service}. The API follows the less-is-more principle, by
+presenting a small interface.")
+ (license license:bsd-3)))
+
(define-public go-github-com-nats-io-nats-go
(package
(name "go-github-com-nats-io-nats-go")