summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 21:28:03 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:26:07 +0000
commitf9ead8f7a832eb0b02b78de5ff379bfa0a1fc310 (patch)
tree109f22add3adf69a5b4d4288a57de923640d0513 /gnu/packages/golang-xyz.scm
parentb5bbfef22a51006945835dabb187ec400429128c (diff)
gnu: go-github-com-burntsushi-toml: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-burntsushi-toml): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/golang-check.scm: Add (gnu packages golang-xyz) module. * gnu/packages/golang.scm: As above. * gnu/packages/shellutils.scm: As above. Change-Id: If8a645431a1fb17159681daae70db49fd21b37c1
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e4b6a09f2d..ee63a78cf7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,8 +1,10 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
+;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
@@ -87,6 +89,29 @@ optimized for sparse nodes of
@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
(license license:expat)))
+(define-public go-github-com-burntsushi-toml
+ (package
+ (name "go-github-com-burntsushi-toml")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BurntSushi/toml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1v9czq4hsyvdz7yx70y6sgq77wmrgfmn09r9cj4w85z38jqnamv7"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/BurntSushi/toml"))
+ (home-page "https://github.com/BurntSushi/toml")
+ (synopsis "Toml parser and encoder for Go")
+ (description
+ "This package is toml parser and encoder for Go. The interface is
+similar to Go's standard library @code{json} and @code{xml} package.")
+ (license license:expat)))
+
(define-public go-github-com-cyberdelia-go-metrics-graphite
(package
(name "go-github-com-cyberdelia-go-metrics-graphite")