summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:20:03 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:34 +0000
commit852d0eab39e7289eee708e138833d4e9596363c5 (patch)
tree93116382b0ebfa8f831790c0b9212fd1a8336ef1 /gnu/packages/golang-xyz.scm
parentaf0b968955c22213f5e55667bcb8b67fda8cc64a (diff)
gnu: Add go-github-com-jinzhu-copier.
* gnu/packages/golang-xyz.scm (go-github-com-jinzhu-copier): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ibff15ec235790b915c852a0d9a33572a05f3374d
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d2e58001cf..33d77e8507 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -538,6 +538,29 @@ Differentiation between text and binary files}.
@end itemize")
(license license:expat)))
+(define-public go-github-com-jinzhu-copier
+ (package
+ (name "go-github-com-jinzhu-copier")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jinzhu/copier")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kf29cmmbic72kfrfd1xnass7l9j85impf8mqn5f3fd3ibi9bs74"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/jinzhu/copier"))
+ (home-page "https://github.com/jinzhu/copier")
+ (synopsis "Go copier library")
+ (description
+ "This package provides a library, which supports copying value from one
+struct to another.")
+ (license license:expat)))
+
(define-public go-github-com-matryer-try
(package
(name "go-github-com-matryer-try")