summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2023-01-17 18:44:48 -0700
committerChristopher Baines <mail@cbaines.net>2023-02-07 00:05:52 +0100
commit0d1caba124fffb0598673f0e2ce57a46885064ff (patch)
treeb248a236f5442c62a85caad1097ba417aaaf5695 /gnu/packages/golang.scm
parent855c203fed8c34bf7d093fe088e32b81c3ae92ec (diff)
gnu: Add go-golang-org-x-exp.
* gnu/packages/golang.scm (go-golang-org-x-exp): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index caf6e1a618..a643efd283 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2855,6 +2855,33 @@ expressing configuration which is easy for both humans and machines to read.")
(home-page "https://github.com/hashicorp/hcl")
(license license:mpl2.0)))
+(define-public go-golang-org-x-exp
+ (package
+ (name "go-golang-org-x-exp")
+ (version "0.0.0-20221004215720-b9f4876ce741")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/exp")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "030b929xyg8dpp6f4qbyg63msi6zgzj9sqmvnyphfcrjkqf7nr41"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/exp"
+ ;; Source-only package
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ (delete 'build))))
+ (home-page "https://golang.org/x/exp")
+ (synopsis "Experimental and deprecated Go packages")
+ (description
+ "This subrepository holds experimental and deprecated (in the @code{old}
+directory) packages.")
+ (license license:bsd-3)))
+
(define-public go-golang-org-x-tools
(let ((commit "8b927904ee0dec805c89aaf9172f4459296ed6e8")
(revision "0"))