summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2023-01-17 18:44:46 -0700
committerChristopher Baines <mail@cbaines.net>2023-02-07 00:05:51 +0100
commit0fd87785bd91bd3fea8be22865310aa57cd4d965 (patch)
tree883f025bf49e9283008a13e81901a170cf52139c /gnu/packages/golang.scm
parent2a6cee99b38f17850bf0e5294b70ce0ee402802d (diff)
gnu: go-golang-org-x-sync: Update to 0.1.0-1.8fcdb60.
* gnu/packages/golang.scm (go-golang-org-x-sync): Update to 0.1.0-1.8fcdb60. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 79d5bc6f9c..cc042e934d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2018, 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2018, 2019, 2020, 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
@@ -3021,11 +3021,11 @@ processing.")
(license license:bsd-3))))
(define-public go-golang-org-x-sync
- (let ((commit "6e8e738ad208923de99951fe0b48239bfd864f28")
+ (let ((commit "8fcdb60fdcc0539c5e357b2308249e4e752147f1")
(revision "1"))
(package
(name "go-golang-org-x-sync")
- (version (git-version "0.0.0" revision commit))
+ (version (git-version "0.1.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3034,17 +3034,17 @@ processing.")
(file-name (git-file-name name version))
(sha256
(base32
- "1avk27pszd5l5df6ff7j78wgla46ir1hhy2jwfl9a3c0ys602yx9"))))
+ "07qrhni6f5hh5p95k1yk6s4wsj341q663irvx6rllrxfsymj6a0z"))))
(build-system go-build-system)
(arguments
`(#:import-path "golang.org/x/sync"
#:tests? #f
;; Source-only package
- #:phases
- (modify-phases %standard-phases
- (delete 'build))))
+ #:phases (modify-phases %standard-phases
+ (delete 'build))))
(synopsis "Additional Go concurrency primitives")
- (description "This package provides Go concurrency primitives in addition
+ (description
+ "This package provides Go concurrency primitives in addition
to the ones provided by the language and “sync” and “sync/atomic”
packages.")
(home-page "https://go.googlesource.com/sync/")