summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:32 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:17 -0400
commit185b5b0c4672ff18bac30b09e33805c2121b6fe7 (patch)
treec71ba0ebf077adcb29fabae51a06dca3a5e6a384 /gnu/packages/golang.scm
parentb334f914036fab2e0d9e7f3ee529abf0fcbdde89 (diff)
gnu: Add go-github-com-jcmturner-goidentity-v6.
* gnu/packages/golang.scm (go-github-com-jcmturner-goidentity-v6): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bccfee0b5d..c80b61ed47 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1458,6 +1458,30 @@ selection based on their relative weighting. This package is useful for
network applications that require accessing services using SRV records.")
(license license:asl2.0)))
+(define-public go-github-com-jcmturner-goidentity-v6
+ (package
+ (name "go-github-com-jcmturner-goidentity-v6")
+ (version "6.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jcmturner/goidentity")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "064ysvxvrvij843s7qj1nkzl5qc6j1qbrsb3s0zmwd1sa7vq8q1n"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jcmturner/goidentity/v6"))
+ (propagated-inputs
+ (list go-github-com-stretchr-testify go-github-com-hashicorp-go-uuid))
+ (home-page "https://github.com/jcmturner/goidentity")
+ (synopsis "Hold authenticated identities and their attributes")
+ (description "This package provides a standard interface for holding
+authenticated identities and their attributes.")
+ (license license:asl2.0)))
+
(define-public go-github-com-jcmturner-gofork
(package
(name "go-github-com-jcmturner-gofork")