summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:26 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:16 -0400
commit2c2c43f877d990f97c14b491611628e977ad222f (patch)
treef851301c99e739a1f8899c33e8c4ea57b689c9fe /gnu/packages/golang.scm
parent6a168919d28f34bc7f4f15f0ce30d7e464a8b363 (diff)
gnu: Add go-github-com-avast-retry-go.
* gnu/packages/golang.scm (go-github-com-avast-retry-go): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index dda0a6cea9..bf6710c2c9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1081,6 +1081,32 @@ cluster segmentation algorithm.")
'(#:unpack-path "github.com/apparentlymart/go-textseg/autoversion"
#:import-path "github.com/apparentlymart/go-textseg/autoversion/textseg"))))
+(define-public go-github-com-avast-retry-go
+ (let ((commit "a322e24d96313ab405dec28ad5711f036c6d25a3")
+ (revision "0"))
+ (package
+ (name "go-github-com-avast-retry-go")
+ (version (git-version "2.4.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/avast/retry-go")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hb4b1668516a4gv8avmflr565b6c1h93phdb068hcjxxj8767ba"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "github.com/avast/retry-go"))
+ (propagated-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/avast/retry-go")
+ (synopsis "Simple golang library for retry mechanism")
+ (description "This package is a simple Go library that provides retry
+functionality for functions that may fail. It includes various customizable
+retry strategies, such as fixed delay, backoff delay, and random delay.")
+ (license license:expat))))
+
(define-public go-github-com-operatorfoundation-shapeshifter-transports
(package
(name "go-github-com-operatorfoundation-shapeshifter-transports")