summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTimo Wilken <guix@twilken.net>2023-04-23 10:41:33 -0400
committerLeo Famulari <leo@famulari.name>2023-04-23 10:45:56 -0400
commit35fe552e91dd9c9e305107c4c245053e41961c98 (patch)
tree3380c03f2bf04b128cb8c49dae1703c80b8b781b /gnu/packages/golang.scm
parent4976208fa8aa4b5b63f51285ca5fff841a20bdba (diff)
gnu: Add go-github-com-coreos-go-systemd-activation.
Required by restic-rest-server; see following commit. * gnu/packages/golang.scm (go-github-com-coreos-go-systemd-activation): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cca5aacdb6..50e57ae506 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8964,6 +8964,29 @@ use one of our glamorous default themes.")
It lets you parse and compare two semantic version strings.")
(license license:asl2.0)))
+(define-public go-github-com-coreos-go-systemd-activation
+ (package
+ (name "go-github-com-coreos-go-systemd-activation")
+ (version "0.0.0-20191104093116-d3cd4ed1dbcf")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coreos/go-systemd")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "193mgqn7n4gbb8jb5kyn6ml4lbvh4xs55qpjnisaz7j945ik3kd8"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/coreos/go-systemd/activation"
+ #:unpack-path "github.com/coreos/go-systemd"))
+ (home-page "https://github.com/coreos/go-systemd")
+ (synopsis "Go bindings to systemd socket activation")
+ (description "Go bindings to systemd socket activation; for writing and
+using socket activation from Go.")
+ (license license:asl2.0)))
+
(define-public go-github-com-emirpasic-gods
(package
(name "go-github-com-emirpasic-gods")