summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2023-01-17 18:44:54 -0700
committerChristopher Baines <mail@cbaines.net>2023-02-07 00:05:53 +0100
commit4b249fcb03b9f021e3778e1e20348aa89cba9024 (patch)
tree2a8f1c8ea9b0c75c73469745597e4c0c6070f026 /gnu/packages/golang.scm
parent1c55f1258e44590c64df15fea08ee7850b189a3c (diff)
gnu: go-github-com-rogpeppe-go-internal: Update to 1.9.0.
* gnu/packages/golang.scm (go-github-com-rogpeppe-go-internal): Update to 1.9.0. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c6c5792204..18823c09e5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9147,7 +9147,7 @@ the necessary APIs to build a wide array of higher-level primitives.")
(define-public go-github-com-rogpeppe-go-internal
(package
(name "go-github-com-rogpeppe-go-internal")
- (version "1.6.1")
+ (version "1.9.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -9156,7 +9156,7 @@ the necessary APIs to build a wide array of higher-level primitives.")
(file-name (git-file-name name version))
(sha256
(base32
- "00j2vpp1bsggdvw1winkz23mg0q6drjiir5q0k49pmqx1sh7106l"))))
+ "0bh08k8fy1qcc0vzyv0xkg0sx5kjx348zd1dpjmp3rbrr6xrpaaw"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/rogpeppe/go-internal"
@@ -9165,6 +9165,8 @@ the necessary APIs to build a wide array of higher-level primitives.")
#:phases
(modify-phases %standard-phases
(delete 'build))))
+ (propagated-inputs
+ (list go-github-com-pkg-diff))
(home-page "https://github.com/rogpeppe/go-internal/")
(synopsis "Internal packages from the Go standard library")
(description "This repository factors out an opinionated selection of