summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-10-21 22:11:31 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:45:59 -0500
commitcc810a72fb25a1920a117bb9b0fce7d25ab8b33c (patch)
tree621997e165b76ce60698c20b55f57c880ab21ffc /gnu/packages/golang.scm
parenta0981f91824887e211b23f7dacdd62388a6206b8 (diff)
gnu: Add go-github-com-go-task-slim-sprig.
* gnu/packages/golang.scm (go-github-com-go-task-slim-sprig): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4d7a1b2be8..15696eab4a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7681,6 +7681,34 @@ maps (because they are not addressable using Go reflection).")
template functions.")
(license license:expat)))
+(define-public go-github-com-go-task-slim-sprig
+ (let ((commit "afa1e2071829e4db655eb448d6c7c16eb0bc5766")
+ (revision "0"))
+ (package
+ (name "go-github-com-go-task-slim-sprig")
+ (version (git-version "2.20.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-task/slim-sprig")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1185y8qygv8gb3wpghx5d945wq68j4dbaiffq3h0dh453g4h1w7a"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/go-task/slim-sprig"
+ ;; Tests try to access the network.
+ #:tests? #f))
+ (home-page "https://github.com/go-task/slim-sprig")
+ (synopsis "Various useful template functions for Go")
+ (description
+ "Sprig provides over 100 functions that extend the Go template system.
+Slim-Sprig is a fork of Sprig that removes all external dependencies to make
+the library more lightweight.")
+ (license license:expat))))
+
(define-public go-github-com-bmatcuk-doublestar
(package
(name "go-github-com-bmatcuk-doublestar")