summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 08:44:15 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commit5abebf71e91d16947d1ade8d4b97a76fc06e2be3 (patch)
tree4fc8d6858611a46211f5b71849bdec610c21a779 /gnu/packages/golang.scm
parentc254415ad113ee99cfa487ba90cff64ce48a24ce (diff)
gnu: go-github-com-mattn-go-runewidth: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/check.scm: Add (gnu packages golang-xyz) module. * gnu/packages/disk.scm: Likewise. * gnu/packages/messaging.scm: Likewise. * gnu/packages/time.scm: Likewise. * gnu/packages/weather.scm: Likewise. Change-Id: I80f8b4c31c0fd8fee7c190a7740513ee139646d4
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0f36c6b696..a8f830e1d9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9186,31 +9186,6 @@ parser.")
@url{https://unicode.org/reports/tr29/, Unicode Standard Annex #29}.")
(license license:expat)))
-(define-public go-github-com-mattn-go-runewidth
- (package
- (name "go-github-com-mattn-go-runewidth")
- (version "0.0.14")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/go-runewidth")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1iaqw5pd7f4f2xz37540kp0828p2820g4vxx3hz089hwl331sx1v"))))
- (build-system go-build-system)
- (arguments '(#:import-path "github.com/mattn/go-runewidth"))
- (propagated-inputs
- (list go-github-com-rivo-uniseg))
- (home-page "https://github.com/mattn/go-runewidth")
- (synopsis "Rune width implementation for Go")
- (description
- "This package provides functions to get the fixed width of a character or
-string.")
- (license license:expat)))
-
-
(define-public go-github-com-charmbracelet-bubbletea
(package
(name "go-github-com-charmbracelet-bubbletea")