summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 15:34:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:43 +0100
commit977490e6350818c41085c710a3b90e31f8caea7f (patch)
treee3fe77d109ec5c03efe1652b8fee2dca724be427 /gnu/packages/golang.scm
parentc1ff8e9efcfac542ed15382a5afec4651ee81d06 (diff)
gnu: go-go-uber-org-goleak: Move to golang-check.
* gnu/packages/golang.scm (go-go-uber-org-goleak): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Iaadd6506457cb3487df8f27f71442a6dcabce816
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b7a376c15f..611a9e883b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8454,30 +8454,6 @@ Gemini clients and servers.")
@code{getopt} for Go.")
(license license:bsd-3)))
-(define-public go-go-uber-org-goleak
- (package
- (name "go-go-uber-org-goleak")
- (version "1.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/uber-go/goleak")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1lpqw7ygffak8qki9i4vw8b99l25l8jrw8iwcplqsclk6fzkl24p"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "go.uber.org/goleak"))
- (native-inputs
- (list go-github-com-stretchr-testify-next))
- (home-page "https://go.uber.org/goleak")
- (synopsis "Goroutine leak detector")
- (description "Go package to verify that there are no unexpected goroutines
-running at the end of a test.")
- (license license:expat)))
-
(define-public go-go-uber-org-multierr
(package
(name "go-go-uber-org-multierr")