summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorDhruvin Gandhi <contact@dhruvin.dev>2022-06-23 15:08:03 +0530
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-10-08 00:10:29 -0400
commit4a47fcbdb4cbbc67330496cee0fc2898f59d4778 (patch)
tree2b0d4e71194e1bf07a041186f9fc2d0c4f773f16 /gnu/packages/golang.scm
parentdbdba682ed2f15c55954577ce98e7e32a4a77fad (diff)
gnu: Add go-github-com-google-shlex.
* gnu/packages/golang.scm (go-github-com-google-shlex): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4a4c706509..4fd9b44c83 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9990,6 +9991,28 @@ production-ready implementation, compatible with the original Jsonnet C++
implementation.")
(license license:asl2.0)))
+(define-public go-github-com-google-shlex
+ (package
+ (name "go-github-com-google-shlex")
+ (version "0.0.0-20191202100458-e7afc7fbc510")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/shlex")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14z8hqyik910wk2qwnzgz8mjsmiamxa0pj55ahbv0jx6j3dgvzfm"))))
+ (build-system go-build-system)
+ (arguments (list #:import-path "github.com/google/shlex"))
+ (home-page "https://github.com/google/shlex")
+ (synopsis "Simple lexer for Go")
+ (description
+ "@code{shlex} implements a simple lexer which splits input into tokens
+using shell-style rules for quoting and commenting.")
+ (license license:asl2.0)))
+
(define-public go-github-com-gorilla-websocket
(package
(name "go-github-com-gorilla-websocket")