summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorDhruvin Gandhi <contact@dhruvin.dev>2022-06-23 15:08:07 +0530
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-10-08 00:10:30 -0400
commitfeee342b66ade14c7b88cb43fe064768ce83409f (patch)
treeba2c3d1fa43d3a91a7e09f45ead8bf3b963fa657 /gnu/packages/golang.scm
parentf0902bd2c0d0dc07197ce202f8a20bfeba91b07a (diff)
gnu: Add go-github-com-lunixbochs-vtclean.
* gnu/packages/golang.scm (go-github-com-lunixbochs-vtclean): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cde002b727..466d571c26 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6082,6 +6082,29 @@ network protocol.")
(home-page "https://github.com/lucas-clemente/quic-go")
(license license:expat)))
+(define-public go-github-com-lunixbochs-vtclean
+ (package
+ (name "go-github-com-lunixbochs-vtclean")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lunixbochs/vtclean")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jqn33l1kzy4dk66zbvxz7rlgkgg34s9mhc8z0lrz0i88466zhd8"))))
+ (build-system go-build-system)
+ (arguments (list #:import-path "github.com/lunixbochs/vtclean"))
+ (home-page "https://github.com/lunixbochs/vtclean")
+ (synopsis "Filter out terminal escape sequences")
+ (description
+ "The @code{vtclean} provides the @command{vtclean} command and a library
+designed to clean up raw terminal output by stripping escape sequences,
+optionally preserving color.")
+ (license license:expat)))
+
(define-public go-github-com-francoispqt-gojay
(package
(name "go-github-com-francoispqt-gojay")