summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-11 11:44:11 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 21:26:39 +0000
commit0f19437ab8c1c4b6e26cdd78ba89f1a0cd18b86b (patch)
tree84fe6cd43413ad01c5240358214e0bab6a9bfaa4 /gnu/packages/golang.scm
parent73867181830f5cb8d885a5404147ef675b1db707 (diff)
gnu: go-github-com-goccy-yaml: Remove benchmarks.
* gnu/packages/golang.scm (go-github-com-goccy-yaml): Remove benchmarks. [arguments] <#:phases>: Add remove-benchmarks phase. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I4249df3ab64d734ebf561e84f6bbc7ed50ff3a1b
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 17db9dd9b9..7daeaa1c86 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8947,7 +8947,13 @@ modifying them.")
(base32 "1nps58dwkd915mx35h5f0dc05b880b4fdl6dcjxpfmmbzyinvg38"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/goccy/go-yaml"))
+ (list
+ #:import-path "github.com/goccy/go-yaml"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-benchmarks
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/benchmarks")))))))
(propagated-inputs
(list go-github-com-fatih-color go-golang-org-x-xerrors))
(native-inputs