summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 21:39:59 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:33:16 +0000
commit19c8f9e0fe0f5489b1fdedab5190e4d0a4cddcb9 (patch)
treeb566408bc4a132db27fe57fee621d1a7721adddd /gnu/packages/golang.scm
parentb8e8cb296f6dc7cc906f50701984c96b9d2508c8 (diff)
gnu: go-golang-org-x-crypto: Move to golang-build.
* gnu/packages/golang.scm (go-golang-org-x-crypto): Move from here ... * gnu/packages/golang-build.scm: ... to here. * gnu/packages/backup.scm: Add (gnu packages golang-build) module. * gnu/packages/crypto.scm: As above. Change-Id: I5daad7fe90e1507958fe73c04fc043ebbc006395
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 98a3167aef..a2073b5c5f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3347,37 +3347,6 @@ expressing configuration which is easy for both humans and machines to read.")
(home-page "https://github.com/hashicorp/hcl")
(license license:mpl2.0)))
-(define-public go-golang-org-x-crypto
- (package
- (name "go-golang-org-x-crypto")
- (version "0.4.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/crypto")
- (commit (string-append "v" version))))
- (file-name (string-append "go.googlesource.com-crypto-"
- version "-checkout"))
- (sha256
- (base32
- "13i0yz4hvc4qdr438nmzilvl5ns73v3910bakcddny3jbzq72i2m"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/crypto"
- ;; Source-only package
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
- (propagated-inputs
- (list go-golang-org-x-sys))
- (synopsis "Supplementary cryptographic libraries in Go")
- (description "This package provides supplementary cryptographic libraries
-for the Go language.")
- (home-page "https://go.googlesource.com/crypto/")
- (license license:bsd-3)))
-
(define-public govulncheck
(package
(name "govulncheck")