summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-31 12:12:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:16:57 +0100
commitcd9089d3d2abfa11668eaf9099f0d875339035d5 (patch)
treedfae9672fe395da52eaad42cdc3b86ba667f7296 /gnu/packages/golang.scm
parent2ec622961cc46fc3833f4f90610ada19c07f72e1 (diff)
gnu: go-github-com-onsi-gomega: Move to golang-check.
* gnu/packages/golang.scm (go-github-com-onsi-gomega): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Ia9a7d0e88ebda2fcfb3fe623163e270756900e94
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 711c007138..3c3d9c7222 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10271,37 +10271,6 @@ serialiser for Go.")
library bevacqua/fuzzysearch.")
(license license:expat)))
-(define-public go-github-com-onsi-gomega
- (package
- (name "go-github-com-onsi-gomega")
- (version "1.19.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/onsi/gomega")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "092phwk97sk4sv0nbx5pfhqs6x3x1lnrjwyda1m6b6zwrfmq5c6i"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/onsi/gomega"
- ;; Unless we disable the tests, we have a circular dependency on
- ;; ginkgo/v2.
- #:tests? #f))
- (propagated-inputs (list go-github-com-golang-protobuf-proto
- go-golang-org-x-net
- go-golang-org-x-sys
- go-golang-org-x-text
- go-google-golang-org-protobuf
- go-gopkg-in-yaml-v2))
- (home-page "https://github.com/onsi/gomega")
- (synopsis "Matcher library for Ginkgo")
- (description
- "Gomega is the preferred matcher library for the Ginkgo test framework.")
- (license license:expat)))
-
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar