summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 16:29:50 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:33:15 +0000
commit2e8b550b56696ef1c8c53c53098bbfc14aaa3ccc (patch)
treebfcf263d1cfa31e4500bb82304cb86c586272b68 /gnu/packages/golang.scm
parent0317445b08413d337c9d654bb15e22f685462d5f (diff)
gnu: go-golang-org-x-mod: Move to golang-build.
* gnu/packages/golang.scm (go-golang-org-x-mod): Move from here ... * gnu/packages/golang-build.scm: ... to here. * gnu/packages/shellutils.scm: Add (gnu packages golang-build) module. Change-Id: I88ce7ac1e264cb545a272f9c8a485747e84f7c82
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 31e8065bff..d796291411 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3699,40 +3699,6 @@ time.")
(home-page "https://godoc.org/golang.org/x/xerrors")
(license license:bsd-3))))
-(define-public go-golang-org-x-mod
- (let ((commit "7c05a442b7c1d1a107879b4a090bb5a38d3774a1")
- (revision "0"))
- (package
- (name "go-golang-org-x-mod")
- (version (git-version "0.7.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/golang/mod")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "14r24fq3kn84k2y2jvvg8hwpy52a3q429pimrdwl5zwknbr2awmh"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/mod/"
- #:tests? #f
- #:phases (modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
- (home-page "https://golang.org/x/mod")
- (synopsis "Tools to work directly with Go module mechanics")
- (description
- "This repository holds packages for writing tools that work directly
-with Go module mechanics. That is, it is for direct manipulation of Go modules
-themselves.
-
-The specific case of loading packages should still be done by invoking the
-@command{go} command, which remains the single point of truth for package
-loading algorithms.")
- (license license:bsd-3))))
-
(define-public go-github-com-hashicorp-go-uuid
(package
(name "go-github-com-hashicorp-go-uuid")