summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:19:56 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:33 +0000
commit4a8db1ec82591730da578b72f09d19ee2ed18a7c (patch)
treef9824ddae308bbd26c2d1efa9a9224377285b9cc /gnu/packages/golang.scm
parentb6231253ce9cf63b4c9d992331e7400023977978 (diff)
gnu: go-github-com-fatih-color: Update to 1.16.0.
Fix lint warning: permanent redirect from <https://godoc.org/github.com/fatih/color> to <https://pkg.go.dev/github.com/fatih/color?utm_source=godoc> * gnu/packages/golang.scm (go-github-com-fatih-color): Update to 1.16.0. [home-page]: Adjust it to resolve lint warning. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I36921eab9350cb3581b58b5cb79fb0e04929045d
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bb22249ec1..8517432f27 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6596,7 +6596,7 @@ filters for Go.")
(define-public go-github-com-fatih-color
(package
(name "go-github-com-fatih-color")
- (version "1.8.0")
+ (version "1.16.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6605,11 +6605,7 @@ filters for Go.")
(file-name (git-file-name name version))
(sha256
(base32
- "1zc0zlilf03h121f9jqq3ar0hfm7706547zysxp2qxbm920pz7h0"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "vendor")))))
+ "15689x103gy9q7g7623rlvhwrw27p079ardapmrrag0sdwrx5bq2"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/fatih/color"))
@@ -6619,7 +6615,7 @@ filters for Go.")
(synopsis "Print colored text in Go")
(description "This package provides an ANSI color package to output
colorized or SGR defined output to the standard output.")
- (home-page "https://godoc.org/github.com/fatih/color")
+ (home-page "https://pkg.go.dev/github.com/fatih/color")
(license license:expat)))
(define-public go-github-com-google-go-cmp-cmp