summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-10 19:19:22 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 21:26:39 +0000
commit9b095daa2986cdb48500f6eb24dc79bf4178705f (patch)
treef4d51a3c75953efed11383acf5fb5decacdab11c /gnu/packages/golang.scm
parentf8d1df5f985d9e38a9fd7ff3100cd52b997342a0 (diff)
gnu: go-github-com-prometheus-procfs: Add missing input.
* gnu/packages/golang.scm (go-github-com-prometheus-procfs): Add missing input. [propagated-inputs]: Add go-golang.org-x-sync-errgroup. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1fa3694524..a4f46eb8ce 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8559,6 +8559,7 @@ Prometheus metrics.")
;; The tests require Go modules, which are not yet supported in Guix's
;; Go build system.
#:tests? #f))
+ (propagated-inputs (list go-golang.org-x-sync-errgroup))
(synopsis "Go library for reading @file{/proc}")
(description "The @code{procfs} Go package provides functions to retrieve
system, kernel, and process metrics from the @file{/proc} pseudo file system.")