summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2024-02-15 20:52:00 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-15 20:52:00 +0000
commit008811aef61626fea834bcd74b5a8575f03e088d (patch)
tree36b2d6447cf75d1d007fd17013971d3e6c590f1f /gnu/packages/golang.scm
parent203344cc37c8a7df1ec1454381b5069d53ce7f9e (diff)
gnu: go-github-com-mattn-go-shellwords: Update to 1.0.12.
* gnu/packages/golang.scm (go-github-com-mattn-go-shellwords): Update to 1.0.12. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Idc4cfdcddacce007cd2d4ba1274a7752a25756e3
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 05989bf287..c9cae358ac 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6057,22 +6057,19 @@ exploration and data entry.")
(license license:expat)))
(define-public go-github-com-mattn-go-shellwords
- (let ((commit "2444a32a19f450fabaa0bb3e96a703f15d9a97d2")
- (version "1.0.5")
- (revision "1"))
(package
(name "go-github-com-mattn-go-shellwords")
- (version (git-version version revision commit))
+ (version "1.0.12")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/mattn/go-shellwords")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "08zcgr1az1n8zaxzwdd205j86hczgyc52nxfnw5avpw7rrkf7v0d"))))
+ "0l0l5s4hlsrm4z6hygig2pp1qirk5ycrzn9z27ay3yvg9k7zafzx"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/mattn/go-shellwords"
@@ -6098,7 +6095,7 @@ exploration and data entry.")
(synopsis "Parse lines into shell words")
(description "This package parses text into shell arguments. Based on
the @code{cpan} module @code{Parse::CommandLine}.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-burntsushi-locker
(let ((commit "a6e239ea1c69bff1cfdb20c4b73dadf52f784b6a")