summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:20:05 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:34 +0000
commit04f2710c5cd91638839a7c0c96873579eb8dc171 (patch)
tree8367ffe743b4fe282636232a98be55cdc9012b44 /gnu/packages/golang.scm
parent156bee7acfe2903b5bc2ae06e6b04e63b0db4667 (diff)
gnu: Add go-github-com-pelletier-go-toml-v2.
* gnu/packages/golang.scm (go-github-com-pelletier-go-toml-v2): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ibc9ee1c7dc3aac1628d2bd32fafc65c23d25c8e8
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 389ce12e34..04425630c0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4054,6 +4054,26 @@ updating files, like @command{tail -f}.")
(description "Go library for the TOML configuration language")
(license license:expat)))
+(define-public go-github-com-pelletier-go-toml-v2
+ (package
+ (inherit go-github-com-pelletier-go-toml)
+ (name "go-github-com-pelletier-go-toml-v2")
+ (version "2.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pelletier/go-toml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k0rwg7870f4va7jaavnpwvdn6d76gxgyr7c978bx2h829a9sx2a"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/pelletier/go-toml/v2"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))))
+
(define-public go-github-com-subosito-gotenv
(package
(name "go-github-com-subosito-gotenv")