summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-15 21:20:32 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-15 21:20:32 +0000
commit3e2334d9457c4bd9ccd9c720de2cf298f0c8f122 (patch)
tree40039e7454990489702086c92448c16402b40094 /gnu/packages/golang.scm
parent7e773e8f05ee9ddee5cb9fd454783cb927d6a30b (diff)
gnu: go-github-com-mattn-go-shellwords: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mattn-go-shellwords): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/terminals.scm: Add (gnu packages golang-xyz) module. Change-Id: Icedf167f4477c6a84fd1b897ca208d6e737efb48
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f6dc0a4f45..7cc532d223 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6056,36 +6056,6 @@ exploration and data entry.")
"The terminfo package implements terminfo database reading for Go.")
(license license:expat)))
-(define-public go-github-com-mattn-go-shellwords
- (package
- (name "go-github-com-mattn-go-shellwords")
- (version "1.0.12")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/go-shellwords")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0l0l5s4hlsrm4z6hygig2pp1qirk5ycrzn9z27ay3yvg9k7zafzx"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/mattn/go-shellwords"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-sh-path
- (lambda* (#:key import-path #:allow-other-keys)
- (substitute* (string-append
- "src/" import-path "/util_posix.go")
- (("/bin/sh") (which "sh"))))))))
- (home-page "https://github.com/mattn/go-shellwords")
- (synopsis "Parse lines into shell words")
- (description "This package parses text into shell arguments. Based on
-the @code{cpan} module @code{Parse::CommandLine}.")
- (license license:expat)))
-
(define-public go-github-com-burntsushi-locker
(let ((commit "a6e239ea1c69bff1cfdb20c4b73dadf52f784b6a")
(revision "0"))