summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2024-01-30 20:08:05 +0000
committerLudovic Courtès <ludo@gnu.org>2024-02-18 16:04:28 +0100
commitb177e753bbf22c7003b17b916fd61c640952ebb2 (patch)
treed22d08307169ba52e3ca19116634c317446712b1 /gnu/packages/golang.scm
parent13e7d4d399182a1146beae802b9608f0b7a43e6c (diff)
gnu: Add go-go-uber-org-goleak.
* gnu/packages/golang.scm (go-go-uber-org-goleak): New variable. Change-Id: I4dd8f244c44ced8910752f67b318c4e39d5acd74 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0b8b656a8e..bde0c74859 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9146,6 +9146,38 @@ Gemini clients and servers.")
@code{getopt} for Go.")
(license license:bsd-3)))
+(define-public go-go-uber-org-goleak
+ (package
+ (name "go-go-uber-org-goleak")
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uber-go/goleak")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lpqw7ygffak8qki9i4vw8b99l25l8jrw8iwcplqsclk6fzkl24p"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:tests? #f
+ #:import-path "go.uber.org/goleak"))
+ (propagated-inputs
+ (list go-github-com-davecgh-go-spew
+ go-github-com-kr-pretty
+ go-github-com-pmezard-go-difflib
+ go-github-com-stretchr-testify
+ go-golang-org-x-lint
+ go-golang-org-x-tools
+ go-gopkg-in-check-v1
+ go-gopkg-in-yaml-v3))
+ (home-page "https://go.uber.org/goleak")
+ (synopsis "Goroutine leak detector")
+ (description "Go package to verify that there are no unexpected goroutines
+running at the end of a test.")
+ (license license:expat)))
+
(define-public go-go-uber-org-atomic
(package
(name "go-go-uber-org-atomic")