summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 15:17:56 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:32 +0000
commitee79286031e87fc7f2e5477a56a9c49b74971080 (patch)
tree1c704d626817b6b1f6a37d8e8b592d1648eeef2e /gnu/packages/golang.scm
parent930692feb0d26c2d9ab5715a2a84196eef13f221 (diff)
gnu: go-github-com-alecthomas-chroma: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-alecthomas-chroma): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/configuration-management.scm: Add (gnu packages golang-xyz) module. Change-Id: I0f5f7068f530b282f3636678e9edc4fad6c8c94a
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c22e4ba005..6eac90bef4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7643,35 +7643,6 @@ synchronizing plain text:
@end itemize\n")
(license license:expat)))
-(define-public go-github-com-alecthomas-chroma
- (package
- (name "go-github-com-alecthomas-chroma")
- (version "0.8.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/chroma")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "066a6rdmf670d3v5sc7chbn7db09ldgxjympb03pcqwk644dixb1"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/alecthomas/chroma"))
- (native-inputs
- (list go-github-com-dlclark-regexp2
- go-github-com-alecthomas-assert
- go-github-com-alecthomas-colour
- go-github-com-alecthomas-repr
- go-github-com-mattn-go-isatty
- go-github-com-sergi-go-diff))
- (home-page "https://github.com/alecthomas/chroma/")
- (synopsis "General purpose syntax highlighter in pure Go")
- (description "Chroma takes source code and other structured text and
-converts it into syntax highlighted HTML, ANSI-coloured text, etc.")
- (license license:expat)))
-
(define-public go-github-com-muesli-reflow-wordwrap
(package
(name "go-github-com-muesli-reflow-wordwrap")