summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 00:12:06 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:20 +0300
commit0a99022229996492eecaba16968dad750c05fa65 (patch)
treef9cf9486a40cb3ac999ab65f8903cb074b05cfce /gnu/packages/golang.scm
parentfa70d264dd1238f72b81eadbbfef41d59c347e04 (diff)
gnu: Add go-github-com-aymerick-douceur.
* gnu/packages/golang.scm (go-github-com-aymerick-douceur): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cafd432cf7..0da0bd30ae 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4734,3 +4734,29 @@ the parse trees produced by the html package.")
(description "@code{goquery} brings a syntax and a set of features similar
to jQuery to the Go language.")
(license license:bsd-3)))
+
+(define-public go-github-com-aymerick-douceur
+ (package
+ (name "go-github-com-aymerick-douceur")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aymerick/douceur/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hfysznib0fqbp8vqxpk0xiggpp0ayk2bsddi36vbg6f8zq5f81n"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/aymerick/douceur"))
+ (native-inputs
+ `(("go-github-com-puerkitobio-goquery" ,go-github-com-puerkitobio-goquery)
+ ("go-github-com-andybalholm-cascadia" ,go-github-com-andybalholm-cascadia)
+ ("go-golang-org-x-net" ,go-golang-org-x-net)
+ ("go-github-com-gorilla-css" ,go-github-com-gorilla-css)))
+ (home-page "https://github.com/aymerick/douceur/")
+ (synopsis "CSS parser and inliner")
+ (description "This package provides a CSS parser and inliner.")
+ (license license:expat)))