summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>2018-05-15 15:23:29 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-23 13:53:14 +0200
commit8c5a69aa0095bd444dc8727683e4796b8f5e0af2 (patch)
tree10cf91e58eceb4bbd6ce4a4126bebb495b43f21a /gnu/packages/golang.scm
parentfb50664f6b0178446836786580e005960a1c2325 (diff)
gnu: Add go-github-com-getsentry-raven-go.
* gnu/packages/golang.scm (go-github-com-getsentry-raven-go): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3b65d58123..8acd528779 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1328,3 +1328,30 @@ systems.")
interface is similar to Go's standard library @code{json} and @code{xml}
package.")
(license license:expat))))
+
+(define-public go-github-com-getsentry-raven-go
+ (let ((commit
+ "dffeb57df75d6a911f00232155194e43d79d38d7")
+ (revision "0"))
+ (package
+ (name "go-github-com-getsentry-raven-go")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/getsentry/raven-go.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13sb9rvl3369m7fah3ss9g0hwky259snqfn8gmbr0h5zvp651lja"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/getsentry/raven-go"))
+ (home-page
+ "https://github.com/getsentry/raven-go")
+ (synopsis "Sentry client in Go")
+ (description "This package is Go client API for the Sentry event/error
+logging system.")
+ (license license:bsd-3))))