summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorRouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>2018-07-10 18:06:06 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-13 00:08:55 +0200
commitaf132bcc001e3715e42fd63eb68fbefce487a170 (patch)
treeb206caccd0f68a6b50b53a04cdf0b53b86950b06 /gnu/packages/golang.scm
parent01bcc94c2f752be165bfe5b8b157cee6889a5bf8 (diff)
gnu: Add go-github-com-docker-machine.
* gnu/packages/golang.scm (go-github-com-docker-machine): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d3694876e2..a5e61b4365 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1867,3 +1867,30 @@ to interacting with distribution components.")
the Go language. In particular it provides tools to deal with network address
translation (NAT), proxies, sockets, and transport layer security (TLS).")
(license license:asl2.0))))
+
+(define-public go-github-com-docker-machine
+ (let ((commit "7b7a141da84480342357c51838be142bf183b095")
+ (revision "0"))
+ (package
+ (name "go-github-com-docker-machine")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/machine.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bavk0lvs462yh0lnmnxi9psi5qv1x3nvzmd2b0drsahlp1gxi8s"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/docker/machine"))
+ (home-page "https://github.com/docker/machine")
+ (synopsis "Machine management for a container-centric world")
+ (description
+ "@dfn{Machine} lets you create Docker hosts on your computer, on
+hosting providers, and inside your data center. It creates servers, installs
+Docker on them, then configures the Docker client to talk to them.")
+ (license license:asl2.0))))