summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 23:16:04 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:18 +0300
commitbdb5a10880faeb2802108d762b4044c440df98c4 (patch)
tree4a3e023aa6c6a6556be43f78d6a17ecbb58a5cc1 /gnu/packages/golang.scm
parent26db4c956dba32b1a3cdaed675915f6d34c84b3e (diff)
gnu: Add go-github-com-bmatcuk-doublestar.
* gnu/packages/golang.scm (go-github-com-bmatcuk-doublestar): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4711ce937d..da5d584ff1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4474,3 +4474,25 @@ maps (because they are not addressable using Go reflection).")
(description "Sprig is a library that provides more than 100 commonly used
template functions.")
(license license:expat)))
+
+(define-public go-github-com-bmatcuk-doublestar
+ (package
+ (name "go-github-com-bmatcuk-doublestar")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bmatcuk/doublestar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/bmatcuk/doublestar"))
+ (home-page "https://github.com/bmatcuk/doublestar/")
+ (synopsis "Path pattern matching and globbing supporting doublestar")
+ (description "@code{doublestar} is a Go implementation of path pattern
+matching and globbing with support for \"doublestar\" patterns.")
+ (license license:expat)))