summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-21 16:19:46 -0400
committerLeo Famulari <leo@famulari.name>2016-10-21 19:13:01 -0400
commit4b0bac4b3ee6cd674b12557f397c35fadd640496 (patch)
treedc867d1849afe2bfe412c8b13114bbcd3fde89c5 /gnu/packages/golang.scm
parent04a95a4fd6677d8bb91b9a1832c407afaa279e4b (diff)
gnu: go-1.4: Skip test that fails due to time zone name change.
* gnu/packages/golang.scm (go-1.4)[arguments]: Skip test "TestLoadFixed" in 'prebuild' phase.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d5813d7903..63e2186a28 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -114,6 +114,13 @@
("net/dial_test.go" "(.+)(TestDialTimeout.+)")
("os/os_test.go" "(.+)(TestHostname.+)")
("time/format_test.go" "(.+)(TestParseInSydney.+)")
+
+ ;; Tzdata 2016g changed the name of the time zone used in this
+ ;; test, and the patch for Go 1.7 does not work for 1.4.3:
+ ;; https://github.com/golang/go/issues/17545
+ ;; https://github.com/golang/go/issues/17276
+ ("time/time_test.go" "(.+)(TestLoadFixed.+)")
+
("os/exec/exec_test.go" "(.+)(TestEcho.+)")
("os/exec/exec_test.go" "(.+)(TestCommandRelativeName.+)")
("os/exec/exec_test.go" "(.+)(TestCatStdin.+)")