summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-12-30 21:24:42 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-12 22:13:22 +0000
commit0edf8a2eabd386d209d4b32aca599ce22a3a7533 (patch)
treeec388debfe5961b03d63d5d283f8542ce959dd61 /gnu/packages/golang.scm
parentf847b47be0b2be480d74685b11fac42babfd41d2 (diff)
gnu: Add go-github-com-peterbourgon-diskv.
* gnu/packages/golang.scm (go-github-com-peterbourgon-diskv): New variable. Change-Id: I0292404c636c42389c11c0ed552bacbf02178f7c Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 060a6b2583..979642c509 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12053,6 +12053,33 @@ using shell-style rules for quoting and commenting.")
ordered, mutable data structure.")
(license license:asl2.0)))
+(define-public go-github-com-peterbourgon-diskv
+ (package
+ (name "go-github-com-peterbourgon-diskv")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/peterbourgon/diskv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pdy8f7bkm65gx4vknwcvfa619hknflqxkdlvmf427k2mzm91gmh"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/peterbourgon/diskv"
+ #:go ,go-1.18))
+ (propagated-inputs (list go-github-com-google-btree))
+ (home-page "https://github.com/peterbourgon/diskv")
+ (synopsis "Disk-backed key-value store")
+ (description
+ "Diskv (disk-vee) is a simple, persistent key-value store written in the Go
+language. It starts with a simple API for storing arbitrary data on a filesystem by
+key, and builds several layers of performance-enhancing abstraction on top. The end
+result is a conceptually simple, but highly performant, disk-backed storage system.")
+ (license license:expat)))
+
(define-public go-github-com-disintegration-imaging
(package
(name "go-github-com-disintegration-imaging")