summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:07 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:30 -0400
commit18a537ec42f25b4497a42b905bacfd03fd30bbee (patch)
tree9064fc737c299a442cfd91e74c61de499296e368 /gnu/packages/golang.scm
parent1261ca098b81b61ed2907c367a05077da591b29d (diff)
gnu: go-github-com-google-go-cmdtest: Move to (gnu packages golang-check).
* gnu/packages/golang-check.scm (go-github-com-google-go-cmdtest): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8860ec50fe..5abe17bf3e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12860,35 +12860,6 @@ production-ready implementation, compatible with the original Jsonnet C++
implementation.")
(license license:asl2.0)))
-(define-public go-github-com-google-go-cmdtest
- (let ((commit "55ab3332a786118933ddf71544aae14951ba9bc5")
- (revision "0"))
- (package
- (name "go-github-com-google-go-cmdtest")
- (version (git-version "0.4.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/go-cmdtest")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "10kswvbdwissjb5mr0ys4b3ppxkxlpklqg7cr2z7rv21g2vwczbl"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/google/go-cmdtest"))
- (propagated-inputs (list go-github-com-google-renameio
- go-github-com-google-go-cmp-cmp))
- (home-page "https://github.com/google/go-cmdtest")
- (synopsis "Testing for your CLI")
- (description
- "The cmdtest package simplifies testing of command-line interfaces. It
-provides a simple, cross-platform, shell-like language to express command
-execution. It can compare actual output with the expected output, and can
-also update a file with new \"golden\" output that is deemed correct.")
- (license license:asl2.0))))
-
(define-public go-github-com-google-safehtml
(package
(name "go-github-com-google-safehtml")