summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2023-12-27 18:43:20 +0100
committerClément Lassieur <clement@lassieur.org>2024-01-12 18:57:45 +0100
commit281f899c21973d253edf52eca556e5f9780c08d1 (patch)
tree6a9185a46893ce1c0ddb9afe30a92de3bd938838 /gnu/packages/golang.scm
parent08e7d92f5e547d1c55de5c00d3f8df212612fa39 (diff)
gnu: Add go-github-com-bwesterb-go-ristretto.
* gnu/packages/golang.scm (go-github-com-bwesterb-go-ristretto): New variable. Change-Id: Icbe3bc2808776d6451ad154653245439173424d5
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1f3d934e2e..c6a1cbc8f2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10022,6 +10022,29 @@ package is intended for interoperability with the standard library and the
@@url{https://filippo.io/edwards25519,edwards25519} package as much as possible.")
(license license:bsd-3))))
+(define-public go-github-com-bwesterb-go-ristretto
+ (package
+ (name "go-github-com-bwesterb-go-ristretto")
+ (version "1.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bwesterb/go-ristretto")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h508v790wk6g8jq0gh18296xl87vmgc4fhwnac7mk6i5g3mz6v4"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/bwesterb/go-ristretto"
+ #:import-path "github.com/bwesterb/go-ristretto/edwards25519"))
+ (home-page "https://github.com/bwesterb/go-ristretto")
+ (synopsis "operations on the Ristretto prime-order group")
+ (description "This is a pure Go implementation of the group operations on
+the Ristretto prime-order group built from Edwards25519.")
+ (license license:expat)))
+
(define-public go-github-com-rogpeppe-go-internal
(package
(name "go-github-com-rogpeppe-go-internal")