summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2023-03-21 09:15:17 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-21 13:48:44 -0400
commit28418027e5041d876f64018a2e3896847d1df9b8 (patch)
treecc0b33f4a23d28ec2ebaabd26ac03329c142564c /gnu/packages/golang.scm
parent8b85aeaa084f36a23bf6e610dfa7fe6d6b96e1a8 (diff)
gnu: Add go-github-com-mitchellh-colorstring.
* gnu/packages/golang.scm (go-github-com-mitchellh-colorstring): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c75fdb4a31..3ac4863e85 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11304,6 +11304,28 @@ kubernetes-sigs/yaml is a permanent fork of
@url{https://github.com/ghodss/yaml,ghodss/yaml}.")
(license (list license:expat license:bsd-3))))
+(define-public go-github-com-mitchellh-colorstring
+ (package
+ (name "go-github-com-mitchellh-colorstring")
+ (version "0.0.0-20190213212951-d06e56a500db")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mitchellh/colorstring")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mitchellh/colorstring"))
+ (home-page "https://github.com/mitchellh/colorstring")
+ (synopsis "Functions to colorize strings for terminal output")
+ (description
+ "Colorstring provides functions for colorizing strings for terminal output.")
+ (license license:expat)))
+
(define-public go-git-sr-ht-emersion-go-scfg
(package
(name "go-git-sr-ht-emersion-go-scfg")