summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:06:45 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:03 +0000
commit2dd97bd8c5409c20611cc55c680f36a28048f38e (patch)
tree0ce9529988ee6d5d0390f5f57155b70b89e228b5 /gnu/packages/golang.scm
parent6a85e9a269e8bc0331af2232cc929c53ff697433 (diff)
gnu: go-github-com-refraction-networking-utls: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-refraction-networking-utls): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I5d27ca70b36e8fae044e54927caab9ffec23347e
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e7ebe189ed..0180d57ad7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3667,42 +3667,6 @@ for the Go language.")
(home-page "https://go.googlesource.com/crypto/")
(license license:bsd-3)))
-(define-public go-github-com-refraction-networking-utls
- (package
- (name "go-github-com-refraction-networking-utls")
- (version "1.6.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/refraction-networking/utls")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1iywar5vqsml4b177k2nkcxmjm8mw92g3p112yjsrpmikiwpwpyw"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/refraction-networking/utls"
- #:go ,go-1.20
- #:tests? #f)) ;requires internet access
- (propagated-inputs
- (list go-github-com-andybalholm-brotli
- go-github-com-cloudflare-circl
- go-github-com-gaukas-godicttls
- go-github-com-klauspost-compress
- go-github-com-quic-go-quic-go
- go-golang-org-x-crypto
- go-golang-org-x-net
- go-golang-org-x-sys))
- (home-page "https://github.com/refraction-networking/utls")
- (synopsis "Fork of the Go standard TLS library, providing low-level access
-to the ClientHello for mimicry purposes")
- (description "uTLS is a fork of “crypto/tls”, which provides ClientHello
-fingerprinting resistance, low-level access to handshake, fake session tickets
-and some other features. Handshake is still performed by “crypto/tls”, this
-library merely changes ClientHello part of it and provides low-level access.")
- (license license:bsd-3)))
-
(define-public govulncheck
(package
(name "govulncheck")