summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:42:12 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:04 +0000
commit42d10bd20160165c5ad89216bdc1b3f6fbff7077 (patch)
treea288f96b48b316ebb4f32a00ada51c7be8c5e903 /gnu/packages/golang.scm
parent4e3526db41cd92306a7a8387d2d92d69fbe4e719 (diff)
gnu: go-github-com-emersion-go-pgpmail: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-emersion-go-pgpmail): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/mail.scm: Add (gnu packages golang-crypto) to used modules. Change-Id: I6e5d284bb045acb30881c79258573c6c79ecc512
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fb9a1c0a7c..2b80b2e9be 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11770,35 +11770,6 @@ text-only mail clients to display them.")
library geared towards parsing MIME encoded emails.")
(license license:expat)))
-(define-public go-github-com-emersion-go-pgpmail
- (package
- (name "go-github-com-emersion-go-pgpmail")
- (version "0.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emersion/go-pgpmail")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ar26b0apw5bxn58qfn1a79cxigbmrqm1irh1rb7x57fydihc7wm"))))
- (build-system go-build-system)
- (arguments
- (list ;; tests don't support our version of protonmail/go-crypto; see
- ;; <https://github.com/emersion/go-pgpmail/issues/12>
- #:tests? #f
- #:import-path "github.com/emersion/go-pgpmail"))
- (propagated-inputs (list go-golang-org-x-text
- go-golang-org-x-crypto
- go-github-com-emersion-go-message
- go-github-com-protonmail-go-crypto))
- (home-page "https://github.com/emersion/go-pgpmail")
- (synopsis "PGP mail encryption for Go")
- (description
- "The pgpmail package implements PGP encryption for e-mail messages.")
- (license license:expat)))
-
(define-public go-github-com-gatherstars-com-jwz
(package
(name "go-github-com-gatherstars-com-jwz")