summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2023-03-21 09:16:38 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-21 14:06:39 -0400
commit441951bb0326503bca8b98c6487fa56f7c08b629 (patch)
treefed0bf3d99c2a40f16a0e6b68db30b4464eda690 /gnu/packages/golang.scm
parent28418027e5041d876f64018a2e3896847d1df9b8 (diff)
gnu: Add go-github-com-schollz-progressbar-v3.
* gnu/packages/golang.scm (go-github-com-schollz-progressbar-v3): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3ac4863e85..b8b4dbd769 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11326,6 +11326,47 @@ kubernetes-sigs/yaml is a permanent fork of
"Colorstring provides functions for colorizing strings for terminal output.")
(license license:expat)))
+(define-public go-github-com-schollz-progressbar-v3
+ (package
+ (name "go-github-com-schollz-progressbar-v3")
+ (version "3.13.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/schollz/progressbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hjahr5r52i7w6iyvl3rpzr46iignhfdh4694fl7m2b4gkaw9gd6"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/schollz/progressbar/v3"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ ;; The full test suite requires Internet access, so only
+ ;; run the short tests.
+ (invoke "go" "test" "-test.short" import-path)))))))
+ (propagated-inputs
+ (list go-golang-org-x-term
+ go-github-com-stretchr-testify
+ go-github-com-mitchellh-colorstring
+ go-github-com-mattn-go-runewidth
+ go-github-com-mattn-go-isatty
+ go-github-com-davecgh-go-spew))
+ (home-page "https://github.com/schollz/progressbar")
+ (synopsis "Simple command-line interface (CLI) progress bar")
+ (description
+ "This package provides a very simple thread-safe progress bar. The
+@code{progressbar} implements an @code{io.Writer} so it can automatically
+detect the number of bytes written to a stream, so you can use it as a
+@code{progressbar} for an @code{io.Reader}. When @code{progressbar}'s length
+is undetermined, a customizable spinner is shown.")
+ (license license:expat)))
+
(define-public go-git-sr-ht-emersion-go-scfg
(package
(name "go-git-sr-ht-emersion-go-scfg")