summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-13 16:27:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-14 13:59:02 +0200
commit455ecb5cbe3201e4c1591ed12650cad6ba34893a (patch)
tree154f4e6a9e81201c125a6421071d873e12c74e8b /gnu/packages/golang.scm
parentae2ecd04fc16577b7a7a7f1fa7ca15631a8a092f (diff)
gnu: go-1.14: On systems not supported by go-1.4 use gccgo-12.
* gnu/packages/golang.scm (go-1.14)[native-inputs]: On systems not supported by go-1.4 replace gccgo-10 with gccgo-12. (go-1.17)[native-inputs]: Remove workaround and inherit from go-1.14.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 829b216cf3..55c489a5d7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -463,7 +463,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(native-inputs
`(,@(if (member (%current-system) (package-supported-systems go-1.4))
`(("go" ,go-1.4))
- `(("go" ,gccgo-10)))
+ `(("go" ,gccgo-12)))
("go-skip-gc-test.patch" ,(search-patch "go-skip-gc-test.patch"))
,@(match (%current-system)
((or "armhf-linux" "aarch64-linux")
@@ -837,13 +837,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
"README.md" "SECURITY.md"))))))))
(inputs (if (not (target-arm?))
(alist-delete "gcc:lib" (package-inputs go-1.16))
- (package-inputs go-1.16)))
- (native-inputs
- (if (not (member (%current-system) (package-supported-systems go-1.4)))
- ;; gccgo-10.4, 11.3 and lower has a bug which causes bootstrapping
- ;; to fail. Use go-1.16 until we have a newer version available.
- (alist-replace "go" (list go-1.16) (package-native-inputs go-1.16))
- (package-native-inputs go-1.16)))))
+ (package-inputs go-1.16)))))
(define-public go-1.18
(package