summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 22:48:34 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:03 +0000
commit540ac7cd5e2bd5a77c16bfa8d4c0bb0857079b62 (patch)
tree90d0707e7054d52ea71448e44d7b894e5bb4a195 /gnu/packages/golang.scm
parent7c4e22b4ad13a50b6f9dc07ef5a8688999359e1b (diff)
gnu: go-github-com-shadowsocks-go-shadowsocks2: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-shadowsocks-go-shadowsocks2): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: Iae18376cae074b6ffb2d5b1b27b6161f4712dfdb
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f83142ce21..0cc1eb11a9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1733,33 +1733,6 @@ https://en.wikipedia.org/wiki/Extended_file_attributes}
mode developed by Halevi and Rogaway.")
(license license:expat)))
-(define-public go-github-com-shadowsocks-go-shadowsocks2
- (package
- (name "go-github-com-shadowsocks-go-shadowsocks2")
- ;; Version > 0.1.3 requires go-toolchain v1.16.
- (version "0.1.3")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/shadowsocks/go-shadowsocks2")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1wzy3ml4ld83iawcl6p313bskzs6zjhz8vlg8kpwgn71cnbv4pvi"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/shadowsocks/go-shadowsocks2"))
- (propagated-inputs
- (list go-github-com-riobard-go-bloom go-golang-org-x-crypto
- go-golang-org-x-net go-golang-org-x-sys go-golang-org-x-text))
- (home-page "https://github.com/shadowsocks/go-shadowsocks2")
- (synopsis "Shadowsocks tunnel proxy")
- (description "Go-ShadowSocks is a Go implementation of the Shadowsocks tunnel
-proxy protocol.")
- (license license:asl2.0)))
-
(define-public go-github-com-schachmat-ingo
(package
(name "go-github-com-schachmat-ingo")