summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 22:52:29 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:03 +0000
commit58c9683d81037758269e424d5cad3ab1e165b9a5 (patch)
tree268c548096b69662131faafe13234fcbc25e6896 /gnu/packages/golang.scm
parent540ac7cd5e2bd5a77c16bfa8d4c0bb0857079b62 (diff)
gnu: go-github-com-libp2p-go-libp2p-peer: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-libp2p-go-libp2p-peer): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I7c372e17f03c9dc18027572582aa8416d59c2cba
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0cc1eb11a9..34584ee80c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6058,41 +6058,6 @@ Reference algorithm has been slightly hacked as to support the streaming mode
required by Go's standard Hash interface.")
(license license:bsd-3)))
-(define-public go-github-com-libp2p-go-libp2p-peer
- (let ((commit "993d742bc29dcf4894b7730ba610fd78900be76c")
- (revision "0"))
- (package
- (name "go-github-com-libp2p-go-libp2p-peer")
- (version (git-version "2.3.8" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/libp2p/go-libp2p-peer")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1h96qjdi0i1wbr0jliap2903mycphas3ny0zdrm77yca9plcnphh"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/libp2p/go-libp2p-peer"))
- (native-inputs
- (list go-github-com-libp2p-go-libp2p-crypto
- go-github-com-gogo-protobuf
- go-github-com-minio-sha256-simd
- go-github-com-minio-blake2b-simd
- go-github-com-btcsuite-btcd-btcec
- go-github-com-mr-tron-base58
- go-github-com-multiformats-go-multihash
- go-github-com-gxed-hashland-keccakpg
- go-github-com-spaolacci-murmur3
- go-golang-org-x-crypto))
- (home-page "https://github.com/libp2p/go-libp2p-peer")
- (synopsis "PKI based identities for use in go-libp2p")
- (description "PKI based identities for use in @command{go-libp2p}.")
- (license license:expat))))
-
(define-public go-github-com-libp2p-go-libp2p-protocol
(let ((commit "b29f3d97e3a2fb8b29c5d04290e6cb5c5018004b")
(revision "0"))