summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 00:03:18 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit65a2f158bbb3415abe83d454d2dc7235e65a77cc (patch)
treefc7ca1796296ac2ad77f2b99c8c0718ea752e1cf /gnu/packages/golang.scm
parent06e70201f3a5a54399fe6de29e6160816d5e4195 (diff)
gnu: go-github-com-minio-sha256-simd: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-minio-sha256-simd): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/backup.scm: Add (gnu packages golang-crypto) to used modules. Change-Id: I4e57a1bee0c7e19a9bb60ce5ff72ccd5e42deea5
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 592b32a7a7..e6a0578b64 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5596,40 +5596,6 @@ provides a default implementation of a subsystem-aware leveled logger
implementing the same interface.")
(license license:isc))))
-(define-public go-github-com-minio-sha256-simd
- (package
- (name "go-github-com-minio-sha256-simd")
- (version "0.1.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/minio/sha256-simd")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1j0iqsckm97g4l79vd4mc7apbmkdar23jpzqpnpdhwpfd834j8lp"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/minio/sha256-simd"))
- (home-page "https://github.com/minio/sha256-simd")
- (synopsis "Accelerate SHA256 computations in pure Go")
- (description "Accelerate SHA256 computations in pure Go using AVX512 and
-AVX2 for Intel and ARM64 for ARM. On AVX512 it provides an up to 8x
-improvement (over 3 GB/s per core) in comparison to AVX2.
-
-This package is designed as a replacement for @command{crypto/sha256}. For
-Intel CPUs it has two flavors for AVX512 and AVX2 (AVX/SSE are also
-supported). For ARM CPUs with the Cryptography Extensions, advantage is taken
-of the SHA2 instructions resulting in a massive performance improvement.
-
-This package uses Golang assembly. The AVX512 version is based on the Intel's
-\"multi-buffer crypto library for IPSec\" whereas the other Intel
-implementations are described in \"Fast SHA-256 Implementations on Intel
-Architecture Processors\" by J. Guilford et al.")
- (license license:asl2.0)))
-
(define-public go-github-com-mr-tron-base58
(let ((commit "d724c80ecac7b49e4e562d58b2b4f4ee4ed8c312")
(revision "0"))