summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-21 20:23:01 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-02 07:03:08 +0200
commit770353c98913d6cc4addf0e6bfc4a60b323f8762 (patch)
tree9949c6446734a16cabfb2074bbe0d3edb76cb4c6 /gnu/packages/golang.scm
parent9e2c51624010d4fb7683b18eab5e653e74986957 (diff)
gnu: Add go-github-com-phpdave11-gofpdi.
* gnu/packages/golang.scm (go-github-com-phpdave11-gofpdi): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6de35767c3..d8dd82e06f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2460,6 +2460,35 @@ parsing and encoding support for STUN and TURN protocols.")
TrueType font files in your system's user and system font directories.")
(license license:expat)))
+(define-public go-github-com-phpdave11-gofpdi
+ (package
+ (name "go-github-com-phpdave11-gofpdi")
+ (version "1.0.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phpdave11/gofpdi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01r8a3k2d48fxmhyvix0ry2dc1z5xankd14yxlm496a26vfnc9nq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/phpdave11/gofpdi"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-source
+ (lambda _
+ (substitute* (find-files "." "writer\\.go$")
+ (("%s-%s") "%d-%s")))))))
+ (propagated-inputs (list go-github-com-pkg-errors))
+ (home-page "https://github.com/phpdave11/gofpdi")
+ (synopsis "PDF document importer")
+ (description
+ "gofpdi allows you to import an existing PDF into a new PDF.")
+ (license license:expat)))
+
(define-public go-torproject-org-pluggable-transports-goptlib
(package
(name "go-torproject-org-pluggable-transports-goptlib")