summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 22:42:35 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:03 +0000
commit7c4e22b4ad13a50b6f9dc07ef5a8688999359e1b (patch)
treeea47f03c71fc8eec023bd90d7629e31732fd1431 /gnu/packages/golang.scm
parent91c79f376aad4edb4accc21b99e420a629ad9616 (diff)
gnu: go-github-com-libp2p-go-libp2p-crypto: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-libp2p-go-libp2p-crypto): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I407bec9b36d61475b2a555643f8bc89b623452e9
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a0983a20d3..f83142ce21 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5868,34 +5868,6 @@ implementations are described in \"Fast SHA-256 Implementations on Intel
Architecture Processors\" by J. Guilford et al.")
(license license:asl2.0)))
-(define-public go-github-com-libp2p-go-libp2p-crypto
- (let ((commit "7240b40a3ddc47c4d17c15baabcbe45e5219171b")
- (revision "0"))
- (package
- (name "go-github-com-libp2p-go-libp2p-crypto")
- (version (git-version "2.0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/libp2p/go-libp2p-crypto")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0qwpy57qv5143l9dlfwfvpqsxdd2i4zwnawx1w4pmgxxim3nw1wb"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/libp2p/go-libp2p-crypto"))
- (native-inputs
- (list go-golang-org-x-crypto go-github-com-btcsuite-btcd-btcec
- go-github-com-gogo-protobuf go-github-com-minio-sha256-simd))
- (home-page
- "https://github.com/libp2p/go-libp2p-crypto")
- (synopsis "Various cryptographic utilities used by IPFS")
- (description "Various cryptographic utilities used by IPFS")
- (license license:expat))))
-
(define-public go-github-com-cloudflare-circl
(package
(name "go-github-com-cloudflare-circl")