summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:09 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:17:18 -0500
commit8177fec860ac2a49dcc539562ea160a740957fae (patch)
tree2199267016da163aadc5d3ac68cb73ea1303b056 /gnu/packages/golang.scm
parented5fed2c4cc5916d0fbed28ca4686acfcb537fdc (diff)
gnu: Add go-github-com-go-test-deep.
* gnu/packages/golang.scm (go-github-com-go-test-deep): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e848074cb4..c4d0a28c32 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10783,6 +10783,30 @@ array or reader.")
ICU to Go.")
(license license:expat)))
+(define-public go-github-com-go-test-deep
+ (package
+ (name "go-github-com-go-test-deep")
+ (version "1.0.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-test/deep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mmw2w3by7y24jjpjwmf2gfl08c65jihn3si9m0sswmagmdsk8q0"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/go-test/deep"))
+ (home-page "https://github.com/go-test/deep")
+ (synopsis "Human-friendly deep variable equality in Go")
+ (description
+ "The deep package provides the deep.Equal function which is like
+reflect.DeepEqual but returns a list of differences. This is helpful
+when comparing complex types like structures and maps.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar