summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-09-01 20:58:15 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-04 22:46:07 -0400
commit843970f634ade17fadb46dd4b61f1b9c3b60951a (patch)
tree96b60d82caf0279063ca856e2c6995794d21575d /gnu/packages/golang.scm
parent8c41567ea508fab07aaee04188c0849210f15db8 (diff)
gnu: Add go-github-com-mreiferson-go-options.
* gnu/packages/golang.scm (go-github-com-mreiferson-go-options): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 262410996c..1aab6b32eb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6400,6 +6400,29 @@ trivial @command{big.Int} encoding benchmark results in 6 times faster
encoding and 8 times faster decoding.")
(license license:expat))))
+(define-public go-github-com-mreiferson-go-options
+ (package
+ (name "go-github-com-mreiferson-go-options")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mreiferson/go-options")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pxs9ybrh196qy14ijn4zn51h2z28lj31y6vxrz2xxhgvpmfmxyl"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mreiferson/go-options"))
+ (home-page "https://github.com/mreiferson/go-options")
+ (synopsis "Go package to structure and resolve options")
+ (description
+ "The @code{options} Go package resolves configuration values set via
+command line flags, config files, and default struct values.")
+ (license license:expat)))
+
(define-public go-github-com-mreiferson-go-svc
;; NSQ specific fork of github.com/judwhite/go-svc, as Guix go build system
;; does not support go.mod with `replace' statement.