summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:53:40 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit857be8fb4713a399120e3357ccb02a89989a7675 (patch)
tree7fc85140acd624d8db1db65589e4f03c4f6108de /gnu/packages/golang.scm
parentfb63bfb9d5d1983aaa67d2ba6447ba7cb71769a6 (diff)
gnu: go-lukechampine-com-blake3: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-lukechampine-com-blake3): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/uucp.scm: Add (gnu packages golang-crypto) to used modules. Change-Id: I56dba8380317a0f58f92140889611ac3075af2cf
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ecfb1ecfc6..7d19b98253 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10451,33 +10451,6 @@ friendly sizes. It converts boring ugly numbers to human-friendly strings and
back.")
(license license:expat)))
-(define-public go-lukechampine-com-blake3
- (package
- (name "go-lukechampine-com-blake3")
- (version "1.1.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lukechampine/blake3")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1yxdwp8dpnnq2wbwsxlkbq570i99sc6781y39czjxi9jh9z5nw55"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "lukechampine.com/blake3"))
- (propagated-inputs
- (list go-github-com-klauspost-cpuid))
- (home-page "https://pkg.go.dev/lukechampine.com/blake3")
- (synopsis "Implementation of the BLAKE3 cryptographic hash function")
- (description "@code{blake3} implements the BLAKE3 cryptographic hash
-function. In addition to the pure-Go implementation, this package also
-contains AVX-512 and AVX2 routines (generated by avo) that greatly increase
-performance for large inputs and outputs.")
- (license license:expat)))
-
(define-public go-golang-org-x-term
(package
(name "go-golang-org-x-term")