summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-03-05 12:54:47 -0800
committerLeo Famulari <leo@famulari.name>2023-03-28 16:26:08 -0400
commit8810be06f2164fe93f5cb3ebee427f41c3512eed (patch)
tree2165027ae288fae21e63ff25d395bd44fe570299 /gnu/packages/golang.scm
parent871a0fe5a38ac72a77a920d048770c2c51ab31c4 (diff)
gnu: Add go-github-com-hanwen-go-fuse-v2.
* gnu/packages/golang.scm (go-github-com-hanwen-go-fuse-v2): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 22984436f2..39d40fe0b8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1158,6 +1158,34 @@ form that bypasses network filtering, allowing the application to work on
networks where it would otherwise be blocked or heavily throttled.")
(license license:expat)))
+(define-public go-github-com-hanwen-go-fuse-v2
+ (let ((commit "915cf5413cdef5370ae3f953f8eb4cd9ac176d5c")
+ (revision "0"))
+ (package
+ (name "go-github-com-hanwen-go-fuse-v2")
+ (version (git-version "2.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hanwen/go-fuse")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ik0yvs9m40vxccpb0rpxc22fyqmcgyysc7w0yl9kn3jyr6qa1d5"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hanwen/go-fuse/v2"))
+ (native-inputs (list
+ go-golang-org-x-sys
+ go-golang-org-x-sync
+ go-github-com-kylelemons-godebug))
+ (home-page "https://github.com/hanwen/go-fuse")
+ (synopsis "Go bindings for FUSE filesystems")
+ (description
+ "This is a repository containing Go bindings for writing FUSE file systems.")
+ (license license:bsd-3))))
+
(define-public go-github-com-kataras-golog
(package
(name "go-github-com-kataras-golog")