summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:10:58 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-11 00:21:23 -0500
commit8835937ea5d708f322aa7ceabcf0d827f38168fc (patch)
tree7a2c584110ab7dc575f831918bfce9ccba2f4b72 /gnu/packages/golang.scm
parenta6d2ae431a900b986eb87cfafb4465269504c211 (diff)
gnu: Add go-google-golang-org-protobuf.
* gnu/packages/golang.scm (go-google-golang-org-protobuf): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2d842cf7be..ab041bf2f0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6777,6 +6777,39 @@ data serialization format.")
(home-page "https://github.com/golang/protobuf")
(license license:bsd-3)))
+(define-public go-google-golang-org-protobuf
+ (package
+ (name "go-google-golang-org-protobuf")
+ (version "1.28.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/protobuf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nzcc4qc00afi24nb7nlnwyzvvr6b8s8qdrn1sw085nygh2y2x8r"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "google.golang.org/protobuf"
+ #:tests? #f ; source-only package
+ #:phases #~(modify-phases %standard-phases
+ ;; source-only package
+ (delete 'build))))
+ (propagated-inputs (list go-github-com-google-go-cmp-cmp
+ go-github-com-golang-protobuf-proto))
+ (home-page "https://google.golang.org/protobuf")
+ (synopsis "Go library for Protocol Buffers")
+ (description
+ "The protobuf package provides a Go implementation of Protocol Buffers, a
+language and platform neutral, extensible mechanism for serializing structured
+data.
+
+This package is a successor to @code{go-github-com-golang-protobuf} with an
+improved and cleaner API.")
+ (license license:bsd-3)))
+
(define-public go-github-com-mattn-go-zglob
(package
(name "go-github-com-mattn-go-zglob")